Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Box Webapp Inaccessible for some users
Incident Report for Box
Resolved
The monitoring period for this issue has ended. No further issues have been observed.
Posted over 1 year ago. Mar 24, 2016 - 15:59 PDT
Monitoring
Some users may have experienced a temporary issue accessing the Box Webapp. We are aware of the issue and have remediated it. We will continue to monitor.
Posted over 1 year ago. Mar 24, 2016 - 13:01 PDT
This incident affected: Box Website.