For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issue with Events API and Box Sign

Incident Report for Box

Postmortem

We recently addressed issues affecting Box Sign as well as Public APIs. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 6:00 PM PDT and 6:42 PM PDT on August, 8th 2023, some users may have experienced issues accessing Box Sign and Public APIs. The issue occurred due to insufficient allocation of resources to a new logging mechanism. We were able to resolve the issue by adjusting the configuration of available resources for this new mechanism. In addition, we added alerts to further monitor the resource usage for this new mechanism across all our services to prevent similar issues from occurring in the future.

Analysis

During this incident, the authorization service within Box started using a new process for exporting logs to remote systems. When the service instances using the new process experienced peak load, traffic exceeded the resource limits allocated for this process. This in turn impacted the authorization service, causing some users to experience difficulty accessing Box Sign and Public APIs.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Increase available resources for the logging mechanism
  • Monitor resource usage for logging mechanism across all services

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Sep 15, 2023 - 11:14 PDT

Resolved

From approximately 18:00 PM to 18:42 PM US Pacific time, we had an issue impacting Events API and Box Sign. Our systems automatically detected and corrected the underlying issue. There is no current impact and no further updates will be provided here. If you are currently seeing any issues, please let us know at https://support.box.com.
Posted Aug 08, 2023 - 18:53 PDT