For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Medium] Issue with Enterprise Reporting

Incident Report for Box

Postmortem

We recently addressed issues affecting the Enterprise Report feature. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

On January 2, 2026 between 5:30 AM and 2:33 PM PST, some users may have experienced difficulties while working in Box. During this time, users were unable to generate some types of Enterprise Reports, and Enterprise Reports scheduled during this time interval may have failed. We were able to resolve the issue by rolling back a configuration change that caused the issues for the reporting engine.

Analysis

Box Enterprise Reports relies on a definition of the schemas that describe the underlying database tables that the engine will consume to generate the reports. As we deliver new products, these schemas may occasionally need to be updated, and we have a standard process and pipeline to deploy these schema. As part of a project to upgrade our pipeline infrastructure, the schema deployment pipeline migrated to a new infrastructure. During the migration process, an external library version upgrade introduced a new default behavior that was not compatible with the existing pipeline. As a result, the Enterprise Reports service could not access the underlying tables in some cases, resulting in a temporary degradation of the service. Additionally, the migration process exposed some observability and guardrails gaps in the pipeline that would have prevented this issue from happening and that extended the impact for a longer period of time.

Once identified, the incompatible library was reverted to the previous version and the system went back to normal.

Corrective Actions

Box has initiated the following corrective actions:

  • Introduce a schema validation step in the deployment pipeline so that incompatible schemas cannot be deployed
  • Enforce the environment promotion process as part of the schema deployment pipeline
  • Uplift the observability of the pipeline to enable more visibility around the different phases of the deployment process

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Jan 14, 2026 - 04:44 PST

Resolved

From approximately 05:30 AM to 02:30 PM US Pacific time, we observed an issue impacting Enterprise Reporting. Customers that attempted to run a report or had a scheduled report during this window may not have the report generated. Reports run during this window should be run again if they have not appeared as expected. There is no current impact and no further updates will be provided here. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Jan 02, 2026 - 05:30 PST