Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Users may see "Sorry, we can't access that page."
Incident Report for Box
Resolved
The issue has been resolved as of 1:42p.m. PST. We apologize for any inconvenience.
Posted almost 2 years ago. Mar 07, 2016 - 13:48 PST
Investigating
We are currently investigating this issue.
Posted almost 2 years ago. Mar 07, 2016 - 13:35 PST
This incident affected: Box Website.