Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] Box Web Application Unavailable
Incident Report for Box
Resolved
Our Engineering team has resolved the issue.
Posted over 2 years ago. Aug 12, 2015 - 17:24 PDT
Monitoring
Access to the Box Web Application has been restored. We will continue to monitor. If you run into any issues, please feel free to reach out to us at https://support.box.com
Posted over 2 years ago. Aug 12, 2015 - 16:03 PDT
Investigating
The Box web application may be unavailable for some users at this time. Engineering teams are investigating.
Posted over 2 years ago. Aug 12, 2015 - 15:56 PDT
This incident affected: Box Website.