Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

View API Users May Have Issues Uploading and Previewing Documents
Incident Report for Box
Resolved
Box Engineers have confirmed that the issue with previewing and uploading content to the Box View API should be resolved at this time.

If you continue to experience any issues accessing Box, please contact the Box User Services team via https://community.box.com/help
Posted 17 days ago. Sep 02, 2017 - 15:25 PDT
Identified
Box Engineering is currently investigating an issue with the View API service.
Posted 17 days ago. Sep 02, 2017 - 14:15 PDT
This incident affected: View API.