Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] Box Web Application may be unavailable for some users
Incident Report for Box
Resolved
We have identified and resolved the source of the issue. Appreciate your patience with Box!
Posted almost 2 years ago. Jul 17, 2015 - 10:57 PDT
Monitoring
We have restored services for Box Web Application and currently monitoring the issue.
Posted almost 2 years ago. Jul 17, 2015 - 09:32 PDT
Investigating
We have identified that the Box Web Application may be intermittent for some users. We are aware of the issue and working to resolve it as soon as possible.
Posted almost 2 years ago. Jul 17, 2015 - 09:11 PDT
This incident affected: Box Website.