On October 1, 2018 Box changed the methodology for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Developer documentation site (developer.box.com) returning intermittent errors
Incident Report for Box
Resolved
No further impact has been observed and we are considering the issue resolved. If you receive any new errors while accessing developer.box.com, please let us know at https://support.box.com.
Posted 6 months ago. Mar 15, 2019 - 15:27 PDT
Identified
We have identified an issue with accessing the developer documentation site (developer.box.com). Users may intermittently see 504 errors when attempting to load pages on developer.box.com. We are working with our third-party vendor to resolve the issue. There is no impact to other Box services. We will provide an update when we can confirm access has been restored.
Posted 6 months ago. Mar 15, 2019 - 08:26 PDT
This incident affected: Developer Console / Docs (developer.box.com).