Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Box Web Application may be unavailable for some users
Incident Report for Box
Resolved
Box services for impacted customers have been fully restored. If you are experiencing issues, please contact us at https://support.box.com.
Posted almost 2 years ago. Mar 13, 2015 - 15:37 PST
Monitoring
Box services for impacted customers have been restored. Teams will continue to actively monitor. If you are experiencing issues, please contact us at support.box.com.
Posted almost 2 years ago. Mar 13, 2015 - 13:58 PST
Identified
We have identified that the Box Web Application may be unavailable for some users. We are aware of the issue and working to resolve it as soon as possible.
Posted almost 2 years ago. Mar 13, 2015 - 13:44 PST
This incident affected: Box Website.