Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Degradation of Uploads, Downloads, and Box Notes
Incident Report for Box
Resolved
The monitoring period has ended, and no further impact has been observed to uploads, downloads, and Box Notes. Our apologies for any inconvenience! If you continue to experience any issues, please contact us at https://support.box.com
Posted 2 months ago. May 22, 2018 - 13:30 PDT
Monitoring
Earlier today from approximately 11:22 AM Pacific to 12:24 PM Pacific, some users may have received errors when attempting to download content, upload content or access Box Notes. We have resolved the underlying issues and confirmed the impact has subsided. We will continue to be in an extended monitoring period to ensure no further impact is observed. Our apologies for any disruption!
Posted 2 months ago. May 22, 2018 - 12:42 PDT
This incident affected: Box Notes and Uploads/Downloads.