On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Issues opening PowerPoint files with Microsoft Online
Incident Report for Box
Resolved
The monitoring period has ended and we are considering the issue resolved. If you experience further issues opening PowerPoint files on Box using Microsoft Online, please let us know at: https://support.box.com.
Posted 21 days ago. Oct 25, 2018 - 15:49 PDT
Monitoring
The root cause of the issue has been identified and a fix has been applied. Users should now be able to open PowerPoint files on Box using Microsoft Office Online again. We are monitoring to ensure no further impact is observed.
Posted 21 days ago. Oct 25, 2018 - 14:54 PDT
Update
We are continuing to investigate issues opening Microsoft PowerPoint files with Microsoft Online through the Box Web App. We are currently engaged with Microsoft to help drive this issue to resolution.
Posted 21 days ago. Oct 25, 2018 - 14:29 PDT
Update
We are continuing to investigate issues opening Microsoft PowerPoint files with Microsoft Online through the Box Web App. We are currently engaged with Microsoft to help drive this issue to resolution.
Posted 21 days ago. Oct 25, 2018 - 13:07 PDT
Investigating
We are currently investigating issues opening Microsoft Powerpoint files with Microsoft Office Online through the Box Web App. The current behavior is the file will attempt load but never completely opens. Only PowerPoint files opened with Microsoft Office Online are impacted..
Posted 21 days ago. Oct 25, 2018 - 11:55 PDT
This incident affected: Partners / Integrations (Microsoft Online).