Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

New Enterprise Users May be Unable to Login to the Box Web App
Incident Report for Box
Resolved
Our engineers have resolved the issue at this time.
Posted about 1 year ago. Jan 08, 2016 - 07:52 PST
Identified
We have identified an issue that may be causing new enterprise users to see an error page when logging in for the first time to the Box Web App. Our engineers are working to resolve this issue at this time.
Posted about 1 year ago. Jan 08, 2016 - 07:39 PST
This incident affected: Box Website.