Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

FTP is unavailable for some Box users
Incident Report for Box
Resolved
All systems are confirmed to be stable. The issue is now resolved.
Posted about 1 year ago. Feb 01, 2016 - 14:06 PST
Monitoring
We have resolved the issue. Engineers will continue monitoring to ensure stability.
Posted about 1 year ago. Feb 01, 2016 - 13:01 PST
Investigating
Some users are having trouble connecting to Box via FTP. We are currently working on resolving this issue.
Posted about 1 year ago. Feb 01, 2016 - 11:35 PST
This incident affected: FTP.