For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Medium] Issues with Box Hubs

Incident Report for Box

Postmortem

We recently addressed an issue affecting Box Hubs. We’d like to take this opportunity to explain what happened and the steps we’ve taken to prevent it from happening again.

Between 06:50 AM PDT to 07:26 AM PDT on July 23, 2026, some users may have experienced difficulties while working in Box. During this time, users attempting to access Box Hubs were unable to load the Hubs gallery and instead encountered a "Not Found" page. The issue occurred as a result of a recent frontend dependency update, which introduced a package version conflict that prevented the Hubs module from loading correctly. We were able to resolve the issue by rolling back the frontend application to the previous stable version, which fully restored access to Box Hubs. In addition, we are working to improve our automated pre-release testing processes to ensure that dependency updates are validated across all affected modules before reaching production, and we are enhancing our monitoring and alerting capabilities to detect and surface similar issues more quickly, to prevent similar issues from occurring in the future.

Analysis

At the technical level, a shared package used by the core web application and the Hubs page module fell out of version alignment when the core application upgraded the dependency without a corresponding update in the Hubs module. This caused the Hubs page to crash at load time. The regression was not caught before reaching production because pre-release automated tests were scoped to core application features and did not cover dependent page modules. Once in production, detection was slowed by monitoring gaps, meaning the incident was ultimately surfaced by synthetic monitoring rather than production observability tooling.

Corrective Actions

Box has initiated the following corrective actions:

  • Improving frontend error monitoring to clearly attribute client-side errors to specific pages, enabling faster detection of page-level failures in production.

  • Enhancing module-level observability and alerting to detect load-time failures for modules. This will ensure we are fully aware of any issues in the integration of sub-modules (such as Hubs) with the core web app as early as possible.

  • Expanding pre-release automated smoke tests to cover all page modules dependent on the core web application, ensuring that package version conflicts are caught in the release pipeline before reaching production.

  • Improving staging environment alerting to surface potential regressions earlier in the release process, before changes are promoted to production.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Jul 30, 2026 - 18:29 PDT

Resolved

After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Jul 23, 2026 - 07:30 PDT

Identified

Box continues remediation efforts to restore full functionality to Box Hubs. The underlying cause of the issue has been identified and efforts are underway to restore usability.
Posted Jul 23, 2026 - 07:26 PDT

Investigating

We are investigating an ongoing issue affecting Box Hubs. We will provide more information as soon as it is available.
Posted Jul 23, 2026 - 07:14 PDT
This incident affected: Box Web Application (Box Hubs).