Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Collaboration Sidebar Not Showing Collaborators
Incident Report for Box
Resolved
The issue with the collaboration sidebar has been resolved. Please submit any new issues to https://support.box.com.
Posted almost 2 years ago. Mar 31, 2015 - 11:45 PDT
Identified
Box Engineering Teams have identified the underlying cause of this behavior and are preparing a fix. We will provide the next update when this fix has been fully tested and released to production.
Posted almost 2 years ago. Mar 31, 2015 - 09:05 PDT
Investigating
The Collaboration sidebar in the Box Webapp is not displaying the list of collaborators for some users and folders. Box Engineering Teams are actively working to resolve this issue.
Posted almost 2 years ago. Mar 31, 2015 - 08:11 PDT
This incident affected: Box Website.