On October 1, 2018 Box changed the methodology for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

Issues with Box Services
Incident Report for Box
Resolved
After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com if you continue to experience any issues.
Posted 3 months ago. Apr 04, 2019 - 03:51 PDT
Monitoring
The affected services in this incident have recovered to full functionality and we are monitoring for any further issues.
Posted 3 months ago. Apr 04, 2019 - 02:55 PDT
Investigating
We are currently investigated issues related to all Box services marked in this incident. We will provide more updates here when available.
Posted 3 months ago. Apr 04, 2019 - 02:29 PDT
This incident affected: Box Notes (Web Application, Desktop Client), Box Web Application (Login/SSO, Uploads/Downloads, Collaboration, Search, Preview, Sharing (Shared Links), Email Notifications, Admin Console & Functionality, Governance (Retention, Legal Holds), Workflows and Automations, Comments and Tasks, Accessible Site (a.box.com)), Box Relay (Relay Tasks, Workflows, and Templates, Relay Workflow API), Desktop Applications (Login/SSO, Box Sync, Box Drive, Box Edit / Tools), Partners / Integrations (Microsoft Online, Apple iWork, Box for Salesforce, Google Apps), Box Platform / API (Content API, Content Preview, Authentication (OAuth 2.0 / JWT), Search, Uploads/Downloads, Webhooks), Mobile Applications (Login/SSO, Preview, Search, Uploads/Downloads, Mobile-Optimized Website (m.box.com)), and FTP, WebDAV, Box Website.