Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Crocodoc Service Not Loading All Documents
Incident Report for Box
Resolved
Intermittent issues with loading documents in Crocodoc has been resolved.
Posted about 1 year ago. Dec 14, 2015 - 08:38 PST
Investigating
Some users of the Crocodoc Service may see that documents are not loading. Engineers are currently investigating.
Posted about 1 year ago. Dec 14, 2015 - 08:00 PST
This incident affected: Crocodoc.