Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Delay in Email Notifications
Incident Report for Box
Resolved
We have not seen any issues with delayed email notifications in the last 24 hours. All services have been fully restored.
Posted almost 2 years ago. Mar 19, 2015 - 10:19 PST
Monitoring
Delayed email notifications have been sent out to the affected users, and have been functioning as expected since around 1 AM PDT. Our teams will continue to monitor. If you are experiencing issues, please contact us at https://support.box.com.
Posted almost 2 years ago. Mar 18, 2015 - 09:23 PST
Update
Delayed notification emails are currently in the process of being delivered to affected customers. We expect the system to be fully caught up this evening.
Posted almost 2 years ago. Mar 17, 2015 - 15:23 PST
Identified
Box is currently experiencing a delay in email notifications for actions performed on files and folders. These emails will be delivered when the issue is resolved.
Posted almost 2 years ago. Mar 16, 2015 - 07:00 PST
This incident affected: Email Notifications.