For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Box Notes Inbox loading issue
Incident Report for Box
Resolved
The monitoring period has ended. No further impact has been observed. If you continue to experience any further issues with Box Notes, please contact us at https://support.box.com
Posted Aug 23, 2018 - 18:45 PDT
Monitoring
We have identified and resolved the issue with the Inbox section for Box Notes.
We are monitoring to ensure no further impact is observed.
Posted Aug 23, 2018 - 18:14 PDT
Investigating
We are currently investigating an issue affecting the "Inbox" section for Box Notes. Some users may see this section is slow to load when in a Box Note.

Loading of the Box Note content itself is not affected nor are the regular web app (Box.com) functions affected.
Posted Aug 23, 2018 - 17:43 PDT