For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Outage] Box Services Unavailable

Incident Report for Box

Postmortem

We recently addressed issues affecting Box and would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 02:18 PM PT and 02:49 PM PT on May 21, 2025, users may have experienced difficulties while working in Box. During this time, Box services and APIs were temporarily unavailable. This was caused by a middleware service that was unable to discover our databases due to a change made in the tooling used to manage our database fleet. We were able to resolve the issue by rolling back the problematic change. In addition, we are improving our database management tool’s observability and rollout process to proactively detect and prevent similar issues from occurring in the future.

Analysis

As part of our routine patching process, we upgraded the tooling used to manage our database fleet. This upgrade was performed before certain prerequisite upgrades on a subset of critical databases. As a result, the updated tooling was incompatible with those databases, causing our middleware service to fail to discover them, leading to a service outage.

The incident highlighted gaps in our database management tool’s upgrade sequencing, rollout validation, and rollback readiness as well as gaps in system observability needed for early detection and remediation of partial discovery failures, all areas we are actively addressing.

Corrective Actions

Box has initiated the following corrective actions:

  • Improve patching upgrade rollout validation
  • Optimize our database management tool’s rollback procedures for faster recovery
  • Enhance system observability for early detection and remediation of partial discovery failures

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted May 22, 2025 - 09:26 PDT

Resolved

After further monitoring, this incident is now considered resolved. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted May 21, 2025 - 16:10 PDT

Monitoring

Our team has taken steps to remediate this issue and is seeing recovery in all metrics. We are continuing to monitor for any additional impact.
Posted May 21, 2025 - 15:07 PDT

Identified

Our team has identified the underlying cause of this issue and is working to take remediating steps. We will provide additional updates as they become available.
Posted May 21, 2025 - 14:59 PDT

Update

We are continuing to investigate this issue.
Posted May 21, 2025 - 14:35 PDT

Investigating

Our team is investigating an issue with multiple Box services. We will provide additional information as it becomes available.
Posted May 21, 2025 - 14:28 PDT
This incident affected: Box Web Application (Login/SSO).