For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Critical] Issues with Multiple Box Services
Incident Report for Box
Postmortem

We recently addressed an issue affecting the use of Collections, Annotations and ability to view and update Sign Settings. We would like to take the opportunity to further explain this issue and the steps we have taken to keep it from happening in the future.

On August 8, 2023 between 12:30 PM PT and 3:30 PM PT, users of Collections, Annotations and Sign features may have experienced difficulties while attempting to load these features. Users saw an error “Failed to load collections” on their left navigation when trying to load Box and also saw an error “Failed to load annotations” when previewing a file with annotations. As part of ongoing efforts to improve our infrastructure at Box, this was part of a planned infrastructure migration. At the time of the migration, these services were unexpectedly operating with less capacity and were unable to serve all traffic. We were able to resolve the issue by increasing the capacity of our infrastructure powering these services.

Analysis

As part of our recent updates to service infrastructure we performed various updates, including ability to automatically scale these services to handle demand in a performant manner. A misconfiguration in connection with these updates inadvertently resulted in a temporary outage of one our services. We have since then provided impacted services appropriate capacity to operate on the new infrastructure and plan to further refine thresholds that will allow us to operate in a more stable and performant manner.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Make sure our service infrastructure has adequate capacity to avoid extended outages.
  • Add additional alerts and monitoring on top of existing monitoring to catch and remediate issues faster.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Aug 15, 2023 - 20:51 PDT

Resolved
After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Aug 08, 2023 - 16:04 PDT
Monitoring
A fix has been implemented and we are currently monitoring the results.
Posted Aug 08, 2023 - 15:53 PDT
Update
We are continuing to investigate this issue.
Posted Aug 08, 2023 - 15:38 PDT
Update
We are continuing to investigate this issue.
Posted Aug 08, 2023 - 14:31 PDT
Investigating
We are investigating an ongoing issue affecting Collections, Annotations, Metadata, and Sign Settings. Users may see errors or slowness with these affected services. We will provide more information as soon as it is available.
Posted Aug 08, 2023 - 14:28 PDT
This incident affected: Box Web Application (Comments and Tasks, Box Sign).