On October 1, 2018 Box changed the methodology for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Medium] Issue loading the Box Web Application in Internet Explorer
Incident Report for Box
Resolved
No further impact has been observed and we are considering the issue fully resolved. If you encounter any new errors while using Box, please let us know at https://support.box.com.
Posted 8 months ago. Jan 18, 2019 - 23:27 PST
Monitoring
We are monitoring to ensure no further impact is observed, and we will provide an update in 30 minutes.
Posted 8 months ago. Jan 18, 2019 - 22:56 PST
Identified
The All Files page should now load completely for users in Internet Explorer. We have identified the source the issue as a recent release and have rolled back the change.
Posted 8 months ago. Jan 18, 2019 - 22:53 PST
Investigating
We are currently investigating an issue loading the Web Application (Box.com) in Internet Explorer. Users on Internet Explorer accessing the All Files page may see the page hang, loading only a blank white page and a colored banner across the top of the screen. We will provide updates as soon as possible.
Posted 8 months ago. Jan 18, 2019 - 22:45 PST
This incident affected: Box Web Application (Uploads/Downloads, Collaboration, Search, Preview, Sharing (Shared Links), Admin Console & Functionality).