Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Box may be unavailable for some users
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further issues have been observed. Please report any issues to Box User Services via https://community.box.com/help
Posted 12 months ago. May 31, 2016 - 14:39 PDT
Monitoring
Box engineers have stabilized all services. We're currently monitoring to ensure there is no further impact from this event.
Posted 12 months ago. May 31, 2016 - 13:30 PDT
Identified
Box Engineering is in the process of restoring access to all Box services impacted by this event.
Posted 12 months ago. May 31, 2016 - 13:12 PDT
Investigating
The Box Web Application and other endpoints (Mobile, API, etc.) may be unavailable to some users. Engineers are actively investigating.
Posted 12 months ago. May 31, 2016 - 12:30 PDT
This incident affected: Box Website, Box Notes, Box Sync, Content API, Downloads, Uploads, Email Notifications, Search, Sharing, Mobile, Metadata, WebDAV, and FTP.