For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issues with Multiple Box Services
Incident Report for Box
Postmortem

We recently addressed issues affecting Uploads, Downloads, Logins, Public API and Box Sign. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 5:24 pm PDT and 5:30 pm PDT on August 22, 2023, some users may have experienced difficulties while working in Box. During this time, some Box users may have experienced increased errors or slowness when accessing Box.com, Uploads, Downloads, Public API, Logins and Box Sign. The issue occurred due to a misconfiguration being applied during an upsize process on one of our database pods, which caused the database pod to become unhealthy when load increased during the issue. We were able to resolve the issue by deploying the correct configuration. In addition, we will be adding alerts to detect the misconfiguration so it can be fixed before causing impact.

Analysis

The database pod involved in this issue was manually upsized on August 3rd as a proactive measure in case of high load. The upsize process used an incorrect command that misconfigured the pod such that it was not able to take advantage of the increased capacity during the issue. During the period of time immediately after the upsize and before the issue, there was an opportunity to detect the misconfiguration and fix it before causing impact, but there is currently no alert in place for that detection.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Alert when a database pod’s runtime configurations are stale

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Sep 21, 2023 - 09:54 PDT

Resolved
After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Aug 22, 2023 - 18:36 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 22, 2023 - 18:12 PDT
Investigating
We are investigating an ongoing issue affecting Public API, Uploads, Downloads and Box Sign. We will provide more information as soon as it is available.
Posted Aug 22, 2023 - 17:55 PDT
This incident affected: Box Platform / API (Content API) and Box Web Application (Uploads/Downloads, Box Sign).