For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] 503 status code on API calls
Incident Report for Box
Postmortem

We recently addressed issues affecting API Calls. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 5:26 PM PDT on October 2, 2024 and 12:50 AM PDT on October 3, 2024, some users may have experienced difficulties while working in Box. During this time, some users may have intermittently experienced “Service Unavailable” errors when using Box.

Analysis

The issue occurred as a result of a single system's degradation that had a disproportionate downstream impact on Box's ability to process all API requests.

Corrective Actions

We were able to resolve the issue by reinstantiating the unhealthy system. In addition, Box will work to proactively identify degraded systems before they cause impact to prevent similar issues from occurring in the future. 

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.

Sincerely,

The Box Team

Posted Oct 29, 2024 - 02:39 PDT

Resolved
After further monitoring, this incident is now considered resolved. API Service has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Oct 03, 2024 - 02:39 PDT
Update
Our team is investigating an issue on API calls. Users might observe some 503 status while running API calls. We will provide additional information as it becomes available.
Posted Oct 03, 2024 - 02:08 PDT
Update
Our team is investigating an issue on API calls. Users might observe some 503 status while running API calls. We will provide additional information as it becomes available.
Posted Oct 03, 2024 - 00:53 PDT
Update
Our team is investigating an issue on API calls. Users might observe some 503 status while running API calls. We will provide additional information as it becomes available.
Posted Oct 03, 2024 - 00:17 PDT
Investigating
Our team is investigating an issue on API calls. Users might observe some 503 status while running API calls. We will provide additional information as it becomes available.
Posted Oct 02, 2024 - 23:47 PDT
This incident affected: Box Platform / API (Content API).