On October 1, 2018 Box changed the methodology for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Issue with Downloads
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further impact has been observed. If you are seeing any issues downloading files from Box, please let us know at https://support.box.com.
Posted 7 months ago. Feb 15, 2019 - 14:22 PST
Monitoring
We have identified and resolved an issue with certain download hosts that was causing the elevated failure rate. We are now monitoring to ensure no further impact is observed.
Posted 7 months ago. Feb 15, 2019 - 13:47 PST
Investigating
We are investigating a slightly elevated download failure rate that started at approximately 12:30 PM US Pacific time. Some users may be seeing errors when downloading files from Box. More information will be provided here as soon as possible.
Posted 7 months ago. Feb 15, 2019 - 13:27 PST
This incident affected: Box Web Application (Uploads/Downloads).