For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issues with API Calls

Incident Report for Box

Postmortem

We recently addressed issues affecting the Box service. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between September 17, 2025 at 11:17 PM and September 18, 2025 at 2:21PM PDT, some users may have experienced difficulties while working in Box. During this time, when attempting to access Box, some users may have seen an unbranded error message which cleared after their browser established a new connection to Box. The issue occurred as a result of a change made by one of Box’s cloud infrastructure providers, and was resolved when the vendor reverted the change. In addition, Box is working closely with our vendor’s engineering team to minimize the likelihood of similar issues occurring in the future. 

Analysis

Box’s cloud provider experienced an issue that caused global load balancer services to incorrectly return HTTP 502 responses for a small percentage of user requests during the following three time periods:

  1. September 17, 2025 from 11:17 PM to 2025-09-18 1:30 AM Pacific
  2. September 18, 2025 from 8:50 AM to 2025-09-18 9:30 AM Pacific
  3. September 18, 2025 from 12:50 PM to 2025-09-18 2:21 PM Pacific

These appear to have been linked to a load balancer software release. Upon discovery, the third-party vendor subsequently performed a rollback at 2:00 PM PT on September 18 to recover the issue. The provider has fixed the bug in their code and will include the fix in future builds.

Corrective Actions

Box has initiated the following corrective actions:

  • Implementation of specific improvements to our alerting system for cloud provider load balancer errors
  • Improved observability to better enable correlation of cloud provider load balancer errors with other conditions
  • Added measures for these particular load balancer conditions as a new Service Level Indicator
  • Increased communication with the cloud provider to detect and resolve this class of issue more quickly

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Sep 23, 2025 - 11:57 PDT

Resolved

After further monitoring, this incident is now considered resolved. API Service has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Sep 18, 2025 - 04:11 PDT

Update

Our team has taken steps to remediate this issue and is seeing improvement on API calls. We are continuing to monitor for any additional impact.
Posted Sep 18, 2025 - 04:01 PDT

Monitoring

Our team has taken steps to remediate this issue and is seeing improvement on API calls. We are continuing to monitor for any additional impact.
Posted Sep 18, 2025 - 03:14 PDT

Update

Our team is investigating an issue with API Calls. You may observe 502 status or "Server Error" while running API Calls. We will provide additional information as it becomes available.
Posted Sep 18, 2025 - 02:55 PDT

Update

Our team is investigating an issue with API Calls. You may observe 502 status or "Server Error" while running API Calls. We will provide additional information as it becomes available.
Posted Sep 18, 2025 - 02:21 PDT

Investigating

Our team is investigating an issue with API Calls. You may observe 502 status or "Server Error" while running API Calls. We will provide additional information as it becomes available.
Posted Sep 18, 2025 - 01:50 PDT
This incident affected: Box Platform / API (Content API).