Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may be experiencing issues with Box Notes
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further impact has been observed. If you continue to experience any issues, please contact Box User Services at https://support.box.com
Posted 3 months ago. Feb 20, 2018 - 15:15 PST
Monitoring
Box Engineers have remediated the incident. All customers should be able to access Box Notes. Engineering will continue to monitor to ensure no further impact is observed before declaring this as resolved.
Posted 3 months ago. Feb 20, 2018 - 15:04 PST
Identified
Box Engineers have identified the root cause of this incident. All users should be able to access Box Notes at this time.
Posted 3 months ago. Feb 20, 2018 - 14:38 PST
Investigating
Box is investigating an issue affecting Box Notes. Impacted users may have experienced delays while attempting to load Box Notes. All users should be able to access Box Notes at this time.
Posted 3 months ago. Feb 20, 2018 - 14:16 PST
This incident affected: Box Notes.