On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Increased Latency with Content API
Incident Report for Box
Resolved
We have concluded monitoring and consider this incident resolved. If you continue to have issues with uploads and downloads through the Box Content API, please let us know at https://support.box.com.
Posted 23 days ago. Oct 23, 2018 - 16:53 PDT
Monitoring
We have taken steps to remediate any increased latency with uploads and downloads through the Box Content API. We will continue monitoring and provide an update at the next status change or in 60 minutes.
Posted 23 days ago. Oct 23, 2018 - 16:13 PDT
Identified
We have identified the root cause of increased latency with uploads and downloads through the Box Content API and are taking steps to remediate.
Posted 23 days ago. Oct 23, 2018 - 16:04 PDT
Investigating
Customers may be experiencing issues and/or increased latency with uploads and downloads using our Content API. We are currently investigating.
Posted 23 days ago. Oct 23, 2018 - 15:53 PDT
This incident affected: Box Platform / API (Content API).