Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some customers may experience issues downloading files
Incident Report for Box
Resolved
As of 4:04pm PDT, the issue with downloading files should now be resolved.
Posted about 3 years ago. Sep 15, 2014 - 16:38 PDT
Investigating
As of 3:30pm PDT, some customers may experience issues when downloading files. We are investigating the issue and will provide an update as soon as we know more.
Posted about 3 years ago. Sep 15, 2014 - 16:01 PDT
This incident affected: Downloads.