About this Site
You trust Box as a valued service provider and partner. You should also trust us to let you know when something is being impacted. With this in mind, we're adopting new practices around communicating service interruptions and outages to keep you informed of what's happening with and within the Box Services. Learn more...

Issue with Uploads
Incident Report for Box
Resolved
From approximately 10:51 AM to 10:54 AM US Pacific time, we had an issue impacting uploads to Box. Our systems automatically detected and corrected the underlying issue. There is no current impact and no further updates will be provided here. If you are currently seeing any issues, please let us know at https://support.box.com.
Posted 11 days ago. Oct 12, 2018 - 10:51 PDT