Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Search results returning no results
Incident Report for Box
Resolved
Box operations team was able to stabilize the search service at 1:40 PM PDT.
Posted almost 3 years ago. Mar 10, 2015 - 13:40 PDT
Investigating
Box search results are showing "Sorry, there are no files of folders that match your search". We're working on a fix.
Posted almost 3 years ago. Mar 10, 2015 - 13:06 PDT
This incident affected: Search.