Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may be experiencing issues with Box Uploads
Incident Report for Box
Resolved
The monitoring period has ended and no further issues have been observed. Please report any outstanding issues to Box User Services via https://community.box.com/help
Posted over 1 year ago. Jul 27, 2016 - 19:19 PDT
Monitoring
Some Box users may have experienced intermittent issues uploading content to Box. Box engineers have stabilized the issue and are currently monitoring to ensure no further impact.
Posted over 1 year ago. Jul 01, 2016 - 17:32 PDT
This incident affected: Uploads.