On October 1, 2018 Box changed the methodology for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Outage] Box University inaccessible
Incident Report for Box
Resolved
Our third-party vendor has resolved the issues impacting the Box University site (box.csod.com). Users should now be able to login to Box University and access all content. This issue is now considered resolved and no further updates will be provided here. If you're still seeing any issues using Box University, please let us know at https://support.box.com.
Posted 3 months ago. Feb 11, 2019 - 21:39 PST
Identified
We are working with our third-party vendor to resolve the issue with Box University. There continues to be no impact to Box services from this issue. The next update will be provided when we can confirm access has been restored.
Posted 3 months ago. Feb 11, 2019 - 13:23 PST
Investigating
We are investigating issues with accessing the Box University site (box.csod.com). Users may see an error about "experiencing some system issues" when attempting to access Box University. The next update will be provided when we can confirm access has been restored. There is no impact to Box services from this issue.
Posted 3 months ago. Feb 11, 2019 - 13:05 PST
This incident affected: Box Community and Support Website (community.box.com) (Box University).