Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Box for iOS App Crashes After Login
Incident Report for Box
Resolved
We have resolved the issue with some enterprises not being able to launch the Box for iOS app. Please report any further issues to us at https://support.box.com.
Posted over 2 years ago. Jan 20, 2015 - 10:16 PST
Investigating
Some enterprises may experience issues launching the Box for iOS app. The app may close after login. Box Engineering teams are actively investigating.
Posted over 2 years ago. Jan 20, 2015 - 09:00 PST
This incident affected: Mobile.