Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Box Mobile App Not Displaying All Folders/Files
Incident Report for Box
Resolved
The issue with the Box Mobile app not displaying all folders/files has been resolved. Please submit any new issues to https://support.box.com.
Posted over 2 years ago. Mar 31, 2015 - 11:45 PDT
Identified
Box Engineering Teams have identified the underlying cause of this behavior and are preparing a fix. We will provide the next update when this fix has been fully tested and released to production.
Posted over 2 years ago. Mar 31, 2015 - 09:05 PDT
Update
[Clarification] Folders impacted by this issue may see the following error in the Box Mobile app "We couldn't load this folder. Please try again."
Posted over 2 years ago. Mar 31, 2015 - 08:41 PDT
Investigating
Some users may find the Box Mobile applications does not display all folders/files. Box Engineering Teams are actively working to resolve this issue.
Posted over 2 years ago. Mar 31, 2015 - 08:36 PDT
This incident affected: Mobile.