On October 1, 2018 Box changed the methodology for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

Upload Service Issues
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further impact has been observed. If you continue to experience any issues, please contact Box User Services at https://community.box.com/t5/Contact-Support/ct-p/BoxSupport
Posted 10 months ago. Feb 09, 2018 - 11:55 PST
Monitoring
Box Engineers have identified the root cause of this incident and have taken immediate steps to remediate. All customers should be able to upload to Box at this time. Engineering will continue to monitor to ensure no further impact is observed before declaring this as resolved.
Posted 10 months ago. Feb 09, 2018 - 11:32 PST
Investigating
Box Engineering is currently investigating an issue with Uploads.
Posted 10 months ago. Feb 09, 2018 - 11:25 PST