Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some customers may experience SSO logins redirecting to account.box.com
Incident Report for Box
Resolved
Our engineers have resolved this issue.
Posted over 1 year ago. Apr 22, 2016 - 00:10 PDT
Identified
We've identified the issue, and will be providing a fix shortly.
Posted over 1 year ago. Apr 21, 2016 - 23:51 PDT
Investigating
We're currently investigating this. As a temporary workaround, please select "Sign In with SSO", enter your email address, and proceed through the login flow.
Posted over 1 year ago. Apr 21, 2016 - 21:00 PDT
This incident affected: Box Website.