Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] Some Users May be Unable to Access https://support.box.com
Incident Report for Box
Resolved
We have resolved this issue, and full access has been restored to all of our users to our Support portal.
Posted over 2 years ago. Jun 01, 2015 - 14:51 PDT
Investigating
Some users may be unable to access the Box Help Center at https://support.box.com. One impact is that when clicking the "Help" link from the Box Webapp a user may be redirected to a blank page. Teams are actively investigating.
Posted over 2 years ago. Jun 01, 2015 - 14:00 PDT