For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issues loading Embed Widget in Integrations
Incident Report for Box
Resolved
After further monitoring, this incident is now considered resolved. Box Embed has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Nov 21, 2024 - 09:48 PST
Monitoring
From approximately 5:30 to 7:50 am PT, the Box Embed in integrations did not load for some customers. A fix has been implemented and we are monitoring the results.
Posted Nov 21, 2024 - 09:06 PST
This incident affected: Box Platform / API (Box Embed Widget).