Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Box Notes Service Unavailable
Incident Report for Box
Resolved
The Box Notes service has been restored. To report an issue, please open a request at https://support.box.com.
Posted almost 3 years ago. Feb 04, 2015 - 20:48 PST
Identified
The Box Notes service is currently unavailable. Users may receive the message "Sorry, we were unable to load your note. Please try again later." Box Engineering Teams are actively working to restore this service.
Posted almost 3 years ago. Feb 04, 2015 - 19:47 PST
This incident affected: Box Notes.