Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some UK-Based Users Unable to Access Box
Incident Report for Box
Resolved
UPDATE 13-Nov-15 11:00am PDT: We have confirmation from users of BT (British Telecom) that the issue has been resolved by the ISP in the UK.
Posted over 1 year ago. Nov 13, 2015 - 12:25 PST
Identified
Our Network Operations team has identified an issue with the BT (British Telecom) ISP that is preventing some users in England and Ireland from connecting to the Box services - Web, Mobile, and Sync. While our internal teams investigate the issue and potential workarounds, we would also ask that you report this issue directly to the ISP to identify any connectivity issues within the network.
Posted over 1 year ago. Nov 13, 2015 - 07:00 PST