For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Critical] Issues with Multiple Box Services

Incident Report for Box

Postmortem

Notice and disclaimer: Box is providing this preliminary information subject to further review and analysis. To the best of our knowledge, this is the current state and we may update as more information is confirmed.

On June 3, 2026 between 10:53 PM and 10:58 PM PDT, some customers may have experienced issues when attempting to sign in to Box and when accessing files, notes, uploads, and our public API.

The issue was caused by a temporary fluctuation in a database shard due to elevated disk activity, which led to connection saturation and service errors for a subset of users. Service returned to normal by 10:58 PM PDT and monitoring remains in place to watch for recurrence. We are also reviewing our deployment and operational practices to reduce the risk of similar incidents in the future.

We are conducting a full engineering postmortem. In the event our continuing investigation yields further substantive findings, we may publish additional analysis after the conclusion of the full engineering postmortem.

We are continuously working to improve Box, and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.

Sincerely,
The Box Team

Posted Jun 09, 2026 - 19:55 PDT

Resolved

From approximately 10:53 PM to 10:58 PM PDT, we observed an issue impacting Login, All Files, Notes, Uploads and Box API. Our systems automatically detected and corrected the underlying issue. There is no current impact and no further updates will be provided here. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Jun 03, 2026 - 10:53 PDT