For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issues with Box for Google Workspace
Incident Report for Box
Postmortem

We recently addressed issues affecting users’ experience with Google Workspace in Box. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between Aug 8, 2023 10:44 AM PT and Aug 9, 2023, 12:16 AM PT, some users may have experienced difficulties while working in Box. During this time, users may have experienced a “Reconnecting” or “Trying to reconnect” error while being blocked from making edits to Google Docs, Sheets and Slides. The issue occurred as a result of a latent bug, arising out of a recent infrastructure change in our ongoing effort to improve performance and stability, that impaired the request validation exchange between Box and Google . We were able to resolve the issue by repairing the validation exchange with Google in order to successfully validate editor requests. In addition, we are working to improve our early detection and testing process to prevent similar issues from occurring in the future. 

Analysis

During infrastructure change testing, the team did not detect this issue through logging or monitoring.

The root cause and fix were identified quickly, however there were various temporary infrastructure issues that prevented quick remediation.

Corrective Actions

The following corrective actions have been completed or are planned:

  • E2E testing of Google Workspace integration prior to any major change.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Aug 24, 2023 - 07:53 PDT

Resolved
After further monitoring, this incident is now considered resolved. Box For Google Workspace service has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Aug 09, 2023 - 02:38 PDT
Monitoring
A fix has been implemented to remediate the issue and Box for Google Workspace service should be returned to full functionality. We are monitoring the results.
Posted Aug 09, 2023 - 00:31 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 08, 2023 - 23:11 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 08, 2023 - 22:09 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 08, 2023 - 21:08 PDT
Identified
We are investigating an ongoing issue affecting access to Box for Google Workspace. Our team has identified the underlying cause of this issue and is working to take remediating steps. We will provide additional updates as they become available.
Posted Aug 08, 2023 - 20:11 PDT
This incident affected: Partners / Integrations (Google Apps).