Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may be experiencing issues with Box Uploads and Downloads
Incident Report for Box
Resolved
The monitoring period has ended and no further impact has been observed. If you continue to experience any issues, please contact the Box User Services team via https://community.box.com
Posted 2 months ago. Dec 13, 2016 - 15:41 PST
Monitoring
Some Box users may have experienced intermittent issues uploading and downloading content to Box. Box engineers have stabilized the issue and are currently monitoring to ensure no further impact.
Posted 2 months ago. Dec 13, 2016 - 15:19 PST
Investigating
Some Box users may be experiencing intermittent issues with downloading and uploading content from and to Box. Engineering is currently investigating the cause of problem.
Posted 2 months ago. Dec 13, 2016 - 14:42 PST
This incident affected: Downloads and Uploads.