For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

Degradation of Box Sign
Incident Report for Box
Postmortem

Notice and disclaimer: Box is providing this preliminary information subject to further review and analysis. To the best of our knowledge, this is the current state and we will update as more information is confirmed.

We recently addressed issues affecting Box Sign. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

 Between January 12, 2022 at 9:50 PM PT until January 13, 2022 at 1:51 AM PT, some users may have experienced difficulties while working in Box. During this time, customers were not able to access Box Sign. The issue occurred due to a new firewall change, and we were able to resolve the issue by rolling back the new change. 

Analysis 

The problematic change had previously been pushed to our development environment without any issues. When pushing the change into our staging and production environments, there was a misconfiguration in the firewall change that blocked some traffic. The change was pushed to staging first, but a misconfiguration in our oncall alerts prevented the alert from properly reaching the oncalls. After 6 hours, this change was implemented in production with the same misconfiguration, which resulted in some service communications being blocked. A mix of the misconfiguration of oncall notification alerts and lack of proactive notifications of changes and change data caused diagnosis of this issue to take extra time.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Changing configurations to correct the oncall notification alert configuration.

  • Changing practices to improve proactive notification of changes and change data. 

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

 

Sincerely,

The Box Team

Posted Jan 20, 2022 - 13:04 PST

Resolved
After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Jan 13, 2022 - 02:04 PST
Update
We are continuing to monitor for any further issues.
Posted Jan 13, 2022 - 02:02 PST
Monitoring
We have resolved the issue impacting Box Sign. We are continuing to monitor to ensure no further impact is observed
Posted Jan 13, 2022 - 02:00 PST
Investigating
Box is investigating reports of an issue with Box Sign. Users of this service may not be able to access it. Box engineers are actively reviewing the issue and will post updates at the next change in status.
Posted Jan 13, 2022 - 01:57 PST
This incident affected: Box Web Application (Box Sign).