Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some Users are Unable to Submit Support Cases on the Box Community
Incident Report for Box
Resolved
The issue with submitting support cases via the Box Community has been resolved. We apologize for any inconvenience.
Posted 11 months ago. Mar 23, 2016 - 12:15 PST
Investigating
Some users may be unable to submit a case through the web form on the Box Community. We are actively investigating.
Posted 11 months ago. Mar 23, 2016 - 10:01 PST