For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Customers may have been experiencing failures when using the Public API
Incident Report for Box
Postmortem

We recently addressed issues affecting Box Drive. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

On Wednesday, August 16th 2023, between 6:52pm and 7:14pm PDT, some users may have experienced difficulties while working in Box. During this time, some users may have experienced delays in Box Drive synchronizing changes. We were able to resolve the issue by allowing our automated recovery to fully complete for the affected service. In addition, we will be refining our auto-scaling tuning to ensure capacity is maintained throughout the duration to prevent similar issues from occurring in the future.

Analysis

Box has been internally migrating services to improve both latency and availability. During this time, a service located in a region outside of its dependencies experienced a partial reduction in available capacity during a shift in traffic to a co-located region. This resulted in additional latency during the recovery that may have been noticed by Box Drive users.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Migrate affected services to be co-located in a single region to minimize latency
  • Tune auto-scaler to ensure planned capacity is available during any future migrations

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Sep 11, 2023 - 10:03 PDT

Resolved
Between 6:51PM and 7:13PM PDT on August 16th, 2023, some users may have experienced failures with Public API services. No further impact has been observed and we are considering this issue to be resolved. If you are still experiencing any issues, please let us know at https://support.box.com
Posted Aug 16, 2023 - 19:38 PDT
This incident affected: Box Platform / API (Content API).