Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may be experiencing delays accessing Box
Incident Report for Box
Resolved
Our engineering team has stabilized all services, this issue is being considered resolved at this time.
Posted 7 months ago. Aug 12, 2016 - 17:25 PST
Investigating
Some users may be experiencing intermittent delays when reaching Box.com and the "All Files" location on the Box web application. Our engineers are currently investigating the issue.
Posted 7 months ago. Aug 12, 2016 - 15:41 PST
This incident affected: Box Website.