About this Site
You trust Box as a valued service provider and partner. You should also trust us to let you know when something is being impacted. With this in mind, we're adopting new practices around communicating service interruptions and outages to keep you informed of what's happening with and within the Box Services. Learn more...

Delay in API Event creation
Incident Report for Box
Resolved
The extended monitoring period for this issue has ended and no further delays have been observed with API Events. If you are seeing any issues with delayed or missing Events, please open a support case with Box User Services at https://support.box.com.
Posted 3 months ago. Jul 17, 2018 - 14:43 PDT
Update
The backlog of delayed Events finished processing around 5:45 AM Pacific today (7/17).

There continues to be no impact or delays to new Event creations after 1:30 PM Pacific yesterday (7/16).

We will complete an extended monitoring period today to ensure no further impact is observed.
Posted 3 months ago. Jul 17, 2018 - 09:33 PDT
Monitoring
The delay issue with API Event creations has been resolved. New actions on Box are creating Events without delay.

Events that should have been created from 4:05 PM Pacific to 4:50 PM Pacific are currently being processed in the backlog along with some Events that were delayed earlier today (10:50 AM Pacific to 1:30 PM Pacific).

We will continue to monitor the backlog and will update here when all previously delayed Events have been processed.
Posted 3 months ago. Jul 16, 2018 - 17:19 PDT
Identified
We have identified a delay with API Events that started around 4:05 PM Pacific and are actively working on remediating the issue. More updates will be provided here as soon as possible.
Posted 3 months ago. Jul 16, 2018 - 16:18 PDT
Monitoring
From 10:50 AM Pacific to 1:30 PM Pacific, API Event creations were backlogged. Applications may be unable to to get Events created during that time until the backlog is processed. New Event creations for actions that happened on Box after 1:30 PM Pacific are not delayed. We will monitor the backlog and update this issue when processing is complete.
Posted 3 months ago. Jul 16, 2018 - 14:05 PDT
This incident affected: Box Platform / API (Content API) and Desktop Applications (Box Sync, Box Drive).